5
Vote

Show context menus for items not working

description

Hi, We just installed the ECQWP and it's working fine, except one thing: Show context menus for items. I only see links to the files. How do i make it work properly? Should i and how do i associate an XSLT file?
 
Thanks for you help!

comments

Kien wrote Jan 2, 2008 at 6:31 PM

Hello,

I'm sort of having the same problem.
If you get the source code, you will find that there are 2 files named ECQWPMain.xslt and ECQWPItems.xslt in the solution folder.

What I did was create a folder named "ECQWP XSL Style Sheets" under the Style Library folder of my site with SharePoint Designer. I then copied those 2 files into this folder and checked them in as a published main version. I then proceeded to add the reference to these 2 files in the webpart (under "Main XSL Link" and "Items XSL Link"). After I've done that, the webpart doesn't display anything at all. It's just blank white.

The strings are:
/Site Library/ECQWP XSL Style Sheets/ECQWPMain.xslt
/Site Library/ECQWP XSL Style Sheets/ECQWPItems.xslt

Am I doing something wrong?

Thanks.

mauleevadi wrote May 20, 2008 at 3:21 PM

Thanks for this post... I was facing this problems & this post help me resolved it.

wrote May 20, 2008 at 3:21 PM

PerryK wrote Apr 28, 2009 at 12:36 PM

Replace in the batchfile everything below 'echo Do you want to activate the...'
with
stsadm.exe -o activatefeature -name "EnhancedContentQueryWebPart" -url "http://TypeHereYourSiteName" -force The Style Sheets library will then be generated with the correct Style Sheets included. Now also the context menus should work fine.

wrote Feb 14, 2013 at 7:11 PM