Does not display additional fields

Jan 6, 2009 at 10:39 AM
Hi,

I am using an Enhanced Content Query web part and I have provided a CAML in the Query Override section to filter certain items in one list. It works fine for me. But I would like to have one more additional fields to get displayed along with 'Title' and 'Last Modified'. 

I had modified the Common View Fields: as follows
CategoryID,Text

CategoryID is one of the fields in my list and is of single line text. Is there anything additionally do I need to do? Any changes in Styles. If yes, can anyone precisely tell me the the exact file and steps.
Sep 15, 2009 at 5:33 AM

Hi, can you please tell how to use Query Override Property in this webpart. for instance i am trying to get all the items in a list where Title equals to "Testdoc" for that i have used U2U tool and built the below query..

<Query><Where><Eq><FieldRef Name="Title" /><Value Type="Text">Testdoc</Value></Eq></Where></Query>

but when i apply this I am getting the error "There is a problem with the query that this Web Part is issuing. Check the configuration of this Web Part and try again"

can you please tell me where i am doing wrong. Thanks much.

Sep 18, 2009 at 2:51 PM
Hey Naresh..

Have you done any modification in the XSLT (inside style library) for displaying the fields..????

Roby

On Tue, Sep 15, 2009 at 11:03 AM, nareshveeragoni <notifications@codeplex.com> wrote:

From: nareshveeragoni

Hi, can you please tell how to use Query Override Property in this webpart. for instance i am trying to get all the items in a list where Title equals to "Testdoc" for that i have used U2U tool and built the below query..

<Query><Where><Eq><FieldRef Name="Title" /><Value Type="Text">Testdoc</Value></Eq></Where></Query>

but when i apply this I am getting the error "There is a problem with the query that this Web Part is issuing. Check the configuration of this Web Part and try again"

can you please tell me where i am doing wrong. Thanks much.

Read the full discussion online.

To add a post to this discussion, reply to this email (ECQWP@discussions.codeplex.com)

To start a new discussion for this project, email ECQWP@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Sep 18, 2009 at 5:09 PM

Hi Roby,

Thanks for the reply. yes i have modified the xslt and added a template to display items in a grid form with headings. good news is that i get it to work after taking out the  <query> tags from the CAML query. and the webpart is working great thanks to all the guys involved in this webpart development. and did you get the CategoryID get to work.. i hope you did, but if you not let me know as i have the solution to display custom fields in the webpart.

Sep 18, 2009 at 8:58 PM
Hi naresh,

I got the CategoryId fine...You can display any of yur custom field displayed.....With ECQWP u can display any fields u provided the ViewField and QueryOverride..with ur xslt given properly...what I feel is there might be something fishy with your XSLT..

try to compare with this blog..I could make it work out with this one....

http://blogs.msdn.com/ecm/archive/2006/10/25/configuring-and-customizing-the-content-query-web-part.aspx

Regards,
Roby

On Fri, Sep 18, 2009 at 10:40 PM, nareshveeragoni <notifications@codeplex.com> wrote:

From: nareshveeragoni

Hi Roby,

Thanks for the reply. yes i have modified the xslt and added a template to display items in a grid form with headings. good news is that i get it to work after taking out the  <query> tags from the CAML query. and the webpart is working great thanks to all the guys involved in this webpart development. and did you get the CategoryID get to work.. i hope you did, but if you not let me know as i have the solution to display custom fields in the webpart.

Read the full discussion online.

To add a post to this discussion, reply to this email (ECQWP@discussions.codeplex.com)

To start a new discussion for this project, email ECQWP@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com