ECWP with Managed Paths error

May 6, 2010 at 7:31 PM

Is this webpart compatible with managed paths? I have a moss webapp with multiple site collections that leverage managed paths. On the root site collection everyting works ok, the webpart works, but on a site collection that uses a managed path, I receive the following error

Unable to display this Web Part. To troubleshoot the problem, open this Web page in a Windows SharePoint Services-compatible HTML editor such as Microsoft Office SharePoint Designer. If the problem persists, contact your Web server administrator.
When I open it in Sharepoint Designer, I get an error that says it could not load the XSL file, The system cannot find the file specified. Now I created these site collections as regular team sites and then activated the Publishing features. Other webparts that I have uploaded to the webapp seem to work ok.
Can anyone provide any feedback on this.

Thank You
<script type="text/javascript">// <![CDATA[ myCtx = new ContextInfo(); myCtx.listBaseType = 1; myCtx.listTemplate = 101; myCtx.listName = "{6e57fe10-ec85-488c-b7ef-678d9ac038ec}"; myCtx.listUrlDir = "Style Library"; myCtx.HttpPath = "/_vti_bin/owssvr.dll?CS=65001"; myCtx.HttpRoot = "http://ifnet/dept/ro"; myCtx.imagesPath = "/_layouts/images/"; myCtx.PortalUrl = "/"; if (myCtx.PortalUrl == "") myCtx.PortalUrl = null; myCtx.displayFormUrl = "http://ifnet/dept/ro/Style Library/Forms/DispForm.aspx"; myCtx.editFormUrl = "http://ifnet/dept/ro/Style Library/Forms/EditForm.aspx"; myCtx.isWebEditorPreview = 0; myCtx.ctxId = 1; myCtx.SendToLocationName=""; myCtx.isForceCheckout = true; var ctxg_3184c59d_e288_4652_b971_7e79fca2d6dc1 = myCtx; // ]]></script>